Database Upgrade

Resolved in a day

Incident timeline

Operational
Resolved
We have published a postmortem here: https://pagertree.com/blog/fly.io-migrate-to-v2-postgres-stuck-in-read-only-mode
2023-07-31 18:28:41 UTC - 2 months
Operational
Resolved
Our database is up in a read/write state. All services are now fully functional. A postmortem will be written on Monday, summarizing the issue, root cause, and remediation. Thank you for your patience and understanding.
2023-07-30 01:43:02 UTC - 2 months
Operational
Monitoring
Our database is back up in a read/write state. We are monitoring at the moment. Thank you for your patience.
2023-07-30 01:16:46 UTC - 2 months
Partial outage
Identified
Still working on the database read only issue. We will post another update in 30 minutes
2023-07-30 00:59:57 UTC - 2 months
Partial outage
Identified
Inserts in the database will be blocked for approximately 10 minutes. Incoming requests will fail. Read requests will succeed.
2023-07-30 00:35:27 UTC - 2 months
Problem detected
Identified
We are currently working through a database upgrade.
2023-07-30 00:31:03 UTC - 2 months